情シス運用記 第4回です。
今回は、前回の記事で紹介したケースの構築編となります。

まずはケース内容のおさらいです。

前回のおさらい

========ケース(2) 業務拡大に伴うファイル共有サーバ導入========

経緯

事務所を開設したA社は、社員の積極的な営業活動もあり、順調に事業が拡大している。
取引先から受領した資料や、社内で作成した資料は各社員がメールで共有しているが
手間が多く、送り先を間違えてしまうリスクがある。
そのため、社内の人間しかアクセスできないファイル共有サーバを導入し、
「円滑な社内コミュニケーション」と「セキュアで簡単なファイル管理」を実現したい。

要件

  • ファイルサーバにアクセスできるのはA社の社員だけ
  • 人事考課資料など、特定のファイルはA社の一部の社員しか閲覧できないような制御がしたい
  • 社内周知資料など、特定のファイルはA社の全社員が閲覧可能、一部の社員が変更可能なよう制御がしたい

技術的に必要な仕組み・設定

・ルータでのサーバ用セグメント設定
  ルータは異なるネットワークセグメント間をつなぐことができます。
  クライアントPCとファイルサーバを異なるネットワークに配置することにより
  管理やアクセス制御がしやすくなります。
・Windowsファイル共有サービス(SMB)
  Windowsのファイル共有サーバは、SMBをインストールすることで実現できます。
  サーバにSMBをインストールし、共有フォルダを設定することで、クライアントPCがアクセスできるようになります。
・Windowsアクセス制御リスト(ACL)
  フォルダへの読み取り/書き込み(Read/Write)など、ユーザやグループ毎に細かく設定することができます。

=========================================

最後に、サーバ・ルータの設定例を紹介します。

〇NW図

〇ルータ(cisco)の設定

!
  interface FastEthernet0/1
  ip address 192.168.1.1 255.255.255.0
  ip nat inside !  interface FastEthernet0/2
  ip address 192.168.2.1 255.255.255.0
  ip nat inside
!
  interface serial 1/0
  ip address 100.1.1.1 255.255.255.252
  ip nat outside
!
  ip nat pool POOL 150.1.1.1 150.1.1.1 netmask 255.255.255.0
  ip nat inside source list 1 pool POOL overload
!
  access-list 1 permit 192.168.1.0 0.0.0.255
  access-list 1 permit 192.168.2.0 0.0.0.255
! 

〇サーバ(Windows)の設定

※画像はWindows Server 2019のものです。

Windowsサーバに「ファイルサーバー」の役割をインストールします。

次に、ファイルサーバにアクセスするユーザと権限グループを作成し、権限グループにユーザを追加します。
※下記では「A_役員」の権限を持つのは「USER001」だけということになります。

ファイルサーバ上に共有するフォルダ(今回は「Share」)を作成、さらにその配下に
個別にアクセス制限するフォルダ(今回は「10.役員専用」)を作成する。
それぞれのフォルダのアクセス許可対象に権限グループを紐づける。

フォルダを共有する。

以上で設定は完了です。

情シス運用記(3) の設計編の記事はこちら。

情シス運用記 (3) ファイル共有サーバの導入~設計編~

他の情シス運用記の記事はこちら。

情シス運用記 記事一覧